Automobiles Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
So I installed the new 034 wideband controller and I no longer am able to communicate with the ECU. I can talk to the wideband controller, but the ECU with not talk to the laptop. The ECU startup screen will only go into the demo mode. Is there something I need to download to update the laptop, such as a driver to give the ECU program an update so it can talk to the laptop. I was able to connect to the ECU yesterday, but couldn't look at the wideband controller, due to the wideband software didn't install correctly. Once I re-downloaded the wideband software and re-installed I could talk to the controller and not the ECU. At a bit of a loss, my IIc is on the v1.02 firmware. Random bit of info I noticed that had changed, the comm was set to comm 3, but now I only have an option for 1 or 2 in the list. Where as it had the list of 16 or so different options before. :? Thanks guys for any help, I could really use it.
Randomly been thinking about this. For sh!ts and giggles, I reloaded the ECU software via the windows installer "repair" feature. After that I was able to communicate with the ECU. So I unplugged the serial cable of the ECU and plugged in the wideband controller and was able to communicate with it. I went back to the ECU and was no longer able to communicate!? Reloaded software again, could see the ECU, could see the wideband, (same process as before). I lose the ability to see the ECU once the wideband is connected, without the ECU connected. Anyone have an idea of why I must reload my ECU software after every time I look into the wideband controller? Seems that this cant be the normal way to run this. :?
Thanks again.
 

·
Registered
Joined
·
2,564 Posts
My guess is that the com# changed after the wideband device instantiated.

If you go to your serial device list you will probably see a new com# in the list, which the ECU software is not configured.
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #3 ·
I have gone in to the device list the ECU is not configured for the comm port. and the ECU only has com 1 and 2, which no matter how I address the comm the ECU and laptop will not communicate until the software gets reloaded into the ECU. Is there a way to keep this from happening? Or is this normal?
 

·
Registered
Joined
·
2,564 Posts
stu2.0t said:
I have gone in to the device list the ECU is not configured for the comm port. and the ECU only has com 1 and 2, which no matter how I address the comm the ECU and laptop will not communicate until the software gets reloaded into the ECU. Is there a way to keep this from happening? Or is this normal?
I am unclear what you are saying.
You went to the device list, do you see multiple devices?
When you unplug them, the device manager should make that device "go away".
You should be able to go to the properties for that device and force it to a specific COM number, so each time
you plug it in, it exists on that COM#.
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #5 ·
the ECU main screen under comm tab usually has 16 options or so. The ECU can be seen on the device manager. Unplug it, plug in the wideband, unplug wideband, plug in ECU it loses all com ports except 1 and 2. When I force the laptop port to become comm port 1 or 2 instead of its normal assignment of three the ECU can no longer be seen by the laptop. I can see the cable plugged into the port, but as if there is nothing on the other end. Once I reload the ECU software everything is back, all the comm ports to select from, 1-16. Then this all goes on after looking at the wideband.
 

·
Registered
Joined
·
2,564 Posts
I would do this:

Plug in the ECUs USB adapter and find that device in the list.
Change the properties so it shows up as COM3. Always plug that adapter to that same exact USB plug position.
USB devices are funny that way.
Unplug the ECU USB adapter.

Next plug in the wideband units USB on a different USB plug position.
Change the properties so it shows up as COM4. Always plug that adapter to that same exact USB plug position.

Now plug both units in and configure each program to the respective COM port that you configured the devices to.

Hopefully that will fix your issue.

One of the biggest problems I have had in diagnosing USB devices is that a given device may always com up
as a specific COM#, but if you install a new device (particularly one that uses the same USB chip), it monkeys
up everything making the devices have differing COM numbers than what you expect.
Then there is the issue of plugging into a different USB plug and it messing things up too.
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #7 ·
I have tried to force my comm port #3, which my ECU normally connects to 1 or 2 since that's what is left for options in the ECU after looking at the wideband. I have the wideband set to comm 6. These ports are not the same ones, I always use different ports for different devices. I believe the problem may lay in the software somewhere. I think at this point I am going to give 034 a call tomorrow, maybe a driver didn't download or install correctly. But thanks for all your help, "TheArchitect" as always.
 
1 - 7 of 7 Posts
Top