Automobiles Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
1,075 Posts
Discussion Starter · #1 ·
So the sunroof that came in my 200 never worked. I tried to diagnose it, figured out why it was not getting power. Once it had power realized that it did not function. The arms that control the tilt/and slide it back function were broken. I tested my parts car sunroof and it worked great.

Pulled the parts cars sunroof, pulled mine. Installed the known good one. I'm sure its just something is not seated right, slid in somewhere, or something. But when it is "neutral" the front is popped up, also it only slide 3/4 the way back (seems to be getting stuck on the roof panel). Also when I go to vent the rear the motor will turn but I have to push on it for it to actually pop up, even then it doesn't vent all the way and the front will come up a bit higher.

My theory is that these sliders are suppose to be in this channel and they are not. But I am not sure, I am about to go read in my bentley and see if it helps me at all but figured I'd post up here first.

Here is some pictures from the crap sunroof to show what I am talking about.


How it currently sits.


How the slider is now.


And with the two black nubbed "arms" in the rail on the inside.

Also if they are suppose to be in there, I'm assuming I need to remove the whole panel to get them to slide in there, correct?
 

·
Administrator
Joined
·
17,168 Posts
Looks like you took it apart way too far. You don't need to disassemble the whole thing to remove it from the car. But yeah that slider looks like it's out of the track.
 

·
Registered
Joined
·
289 Posts
from the front lifting as well as the rear when venting, it seems its not in the rails or the bracket is not bolted down with the black screws. Trying to put an image together from memory, ill have to check it out when im out of the office.
 

·
Registered
Joined
·
1,075 Posts
Discussion Starter · #4 ·
The only screws not installed are the two at the very rear (one on each side). I can't install them because it won't slide back far enough. I think I am going to have to remove it again, try to slide it in the rail this time and see what happens.
 

·
Registered
Joined
·
1,075 Posts
Discussion Starter · #6 ·
Round 2 of me vs the sunroof.

Took it out. Played with it for a bit got the nubs in the rail. Broke this small clip at the back on a horizontal bar, went to just pop it off the old one. Couldn't find it. Hmmm odd. Kept looking and and looking.

Well figured out why the sunroof wasn't going back all the way.



Well isn't that a bitch lol. Go fucking figure it broke off my old shitty sunroof.

Fished it out!


Put it back on real quick.

Good:
it sits flat
it slides when not installed on the car

Bad:
doesn't slide when installed (due to the back hitting the roof skin)
Sooooooo it's not perfect but it is progress. Need to figure out why the back won't dip down enough to slide it back, once I figure that out I should be golden.

Oh and when I was about to finish I popped the spring that pops up the vent off, lol oh well. I'll deal with it all tomorrow. Need to step away from it start fresh with a clear head.

Still need clarification on what is suppose to go in the track and what is suppose to slide on top if anyone can help.

I should be a sunroof expert when I finally fix this lol.
 

·
Registered
Joined
·
686 Posts
Sunroof on this car is maddening...my BMW friends just laugh at me. I guess theirs is much easier to maintain...
but...I won't spin out in the snow..
 

·
Registered
Joined
·
7,384 Posts
Sunroof fun :)

They can be made easier to understand. I have a factory sunroof manual scanned into a PDF, but I am not sure if it covers the 200 or not (if its the same as the 5000 it would probably work). Just getting the adjustments right is what you need to do, pending all the other parts are there and not broken.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top